Power Product’s Response to HeartBleed Vulnerability

heartbleed-imageWe wanted to take a moment and let our customers and blog readers know that none of our Websites Diesel, Offroad, Towing, Big Rig or Fuel Bomb were susceptible to the recent Heartbleed bug. We have never used OpenSSL on any of our servers. This means that none of our customer’s usernames, passwords, credit card information or anything else security related was ever compromised.

Heartbleed if you do not know is a bug that was recently found on servers that specifically use OpenSSL. This is a very common server tool and it is estimated about 2/3rds of the sites on the internet use OpenSSL primarily because it is a free tool and has never had an issue before. The bug has been around for 2 years without public knowledge. You can read up more on Heartbleed here.

If you are concerned about Heartbleed, there are a few tools that you can use. Chrome has created a tool that you can integrate into your Chrome browser to know if a site you are using has not been fixed yet. Here is the link. If you use firefox there is a tool also, here is the link. Currently I do not know of a fix for Internet Explorer or Safari.  If you have questions or comments, please leave them in the comments section below and I will answer them ASAP.

We are now going to get back to the exciting world of diesel trucks.

Leave a Reply

Your email address will not be published. Required fields are marked *